Symptom: Unexpected power button behaviour (Podium Series)

We have determined that the power button issue was caused (ironically) by an additional quality test performed during manufacturing, which damaged some units and we were not able to filter all those units out. The failure rate is extremely low - bear in mind that this is the biggest launch of any direct drive system ever made.

The issue has already been solved in production.

If your Podium Series Wheel Base / Racing Wheel exhibits any unusual behaviour when operating the power button, please contact our support team, and we will repair or exchange your unit immediately.

Comments

  • i hope the batch 2019-08-16 befor gonna be sent to the custumers go tru additional quality test
  • Does this issue affect also DD2?
    I guess that many of us use the killswitch remote power button and not the power button at the back, on DD2.
  • Does this issue affect also DD2?
    I guess that many of us use the killswitch remote power button and not the power button at the back, on DD2.
    Yes it can affect the DD2. Affected units will exhibit this behaviour on both the base and killswitch power buttons.
  • Thanks Dominic for your reply.
    I use DD2 everyday since 30th april and didn't have yet this issue... Hope that my unit is not affected... Cross fingers.
  • Yippie, I am a lucky guy.... after waiting almost 1 year (and idirectly paid)....
    Now in the third day of use (less than 2 hours in total  of use), I cannot switch off my device with the power button!!! And I cannot confirm the high torque with any button... the only thing which helps is to plug off the whole dd1... Annoying ... 
  • Guys, now I`m getting really angry...

    I cannot start my support request without the serial no....
    It says, it's at the bottom, really? why are you not able to put it at the back, where everybody can have a quick look on it... now I have to dissasembly my whole rig....
  • Guys, now I`m getting really angry...

    I cannot start my support request without the serial no....
    It says, it's at the bottom, really? why are you not able to put it at the back, where everybody can have a quick look on it... now I have to dissasembly my whole rig....
    The serial number is under the top plate - held on by magnets.
  • edited May 13
    And now the best of all...
    There is no serial number at the bottom!!!

  • And now the best of all...
    There is no serial number at the bottom!!!
    There is no serial number at all at the device!!!
    There is, its under the top plate - held on by magnets
  • edited May 13
    Thanks Neil! You are right, unfortnately I haven't read your post (I think there is a delay between posting and the visibility for others?), before I wrote my last one... after disassembling my rig
  • edited May 14
    Mine was shipped back yesterday for this issue. Thank you so much for filling us in about the details.
  • edited May 14
    I'm so done being patient. This is real annoying, I'm not gonna pretend to be ok with this. Definitely no longer a promoter of fanatec they've done nothing but drop the ball.  The most frustrating/expensive purchase i've made in a while and it still doesn't seem like they truly care. Its all about profit for these guys clearly and that will be the undoing.
  • DAMNIT, DAMNIT, SON OF A ****!!!!!!!!! 
    I know these things happen, so I won't throw a tantrum beyond what I just said. I was hoping not to find a post like this and be lucky enough to be the first. I'm unlucky enough to know that this will likely hit most of the first batch. I put in about 15 hours of use on the wheel before the power button stopped being a power button.

    I opened a support ticket...
  • edited May 14
    I'd really like some assurance from Fanatec on whether this is going to be a common problem among those of us who received our Podium base in the first batch. Like eveyone else I suspect, I'm quite nervous about this.

    Was the 'quality test' that causes the issue done on all bases, or only a few picked randomly from the production line?
  • Ditto Josh, would be good to know more!

  • ... it still doesn't seem like they truly care. Its all about profit for these guys clearly and that will be the undoing.

    What part of
    ...If your Podium Series Wheel Base / Racing Wheel exhibits any unusual behaviour when operating the power button, please contact our support team, and we will repair or exchange your unit immediately.
    makes you feel that Fanatec does not care and is only in it for the profit?
  • First production run of a brand new product - these things happen. It's unfortunate but it's true. Fanatec are handling it well, they've held their hand up to the problem, given the background and are giving priority exchanges to those affected. What else do those unhappy expect?
  • What behavior should I be looking out for in my wheelbase?
  • Is it possible that the power button issue is  a result of firmware?
  • What behavior should I be looking out for in my wheelbase?
    Power button does not power the screen off. If connected to a pc, you'll hear the usb disconnect when powering off, but the display remains on and fans running. The only way to power off is to unplug from the power unit. I also had a couple of occasions where when plugging in to power the wheel would spin many times with the fan blowing very strong.
    Is it possible that the power button issue is  a result of firmware?
    I can't say for certain. What I can say is that reflashing firmware did not resolve the issue.

    The wheel IS usable in this state, you just have to unplug it to power off. Fanatec has responded and requested a video and the serial number. I'm still waiting for RMA approval.
  • Which firmware did you have? 651 or 653?
  • Attach a link to a video about how the power button is defective when you make the RMA. It saves some time. Serial number can be found also on the box btw. I sent a message to Fanatec that I have shipped my defective DD1 on tuesday and they'll be shipping a new unit to me in thursday. So its nice that they send a new DD before they receive my old DD.
  • Serial number is also under the top panel.  

    The top panel is magnetic and easily removed.
  • Now, more information by my side about the contact with the fanatec support:
    the failure on my DD2 is sporadic, so I couldn't make a video yet... by trying to test it, I got an other failure: after starting the cold DD1 the fan went to maximum speed ( I thought it will burn through) until I pressed the power button again.

    But the guy from the support mean: "then you have now no problem, right?"
    And that  I can sent the DD1 back to fanatec, but when they don't find the failure at the moment, I will have to pay the shipping!?! 

    Oh guy, I have a problem, when a 1000€ wheel base shows 2 types of failure within 2-3 hours of use!

    Really poor support FANATEC....
  • I am having the same power button issue.  Additionally have had to re calibrate each time I power it back on from the mains.  

    If I have to RMA, who pays for shipping? 
     I am halfway across the globe and will be without a wheel not factoring in the annoyance of having to disassemble and reassemble everything again ...sorry for the vent but this really pisses me off.

    I have invested in Fanatec for the last 5 years and pre-ordered in trust and good faith despite delays.  I think Fanatec should just send us a replacement wheel ahead of us shipping back the defective one as a return of that trust.


  • It would seem like it is more than just a few units that are compromised after all.
  • It would seem like it is more than just a few units that are compromised after all.

    This can't be possible, they delayed release for several months to make the product perfect and iron out the mystery issue that affected .07% of DD units...

    So it's reasonable to expect that this is one of the most thoroughly tested and perfected products ever released. And you're suggesting Fanatec could have missed something so fundamental during such an intensive period of product development...?

    Inconceivable.

  • It would seem like it is more than just a few units that are compromised after all.

    This can't be possible, they delayed release for several months to make the product perfect and iron out the mystery issue that affected .07% of DD units...

    So it's reasonable to expect that this is one of the most thoroughly tested and perfected products ever released. And you're suggesting Fanatec could have missed something so fundamental during such an intensive period of product development...?

    Inconceivable.

    Haha, you are oozing sarcasm
  • edited May 17
    I am having the same power button issue.  Additionally have had to re calibrate each time I power it back on from the mains.  

    If I have to RMA, who pays for shipping? 
     I am halfway across the globe and will be without a wheel not factoring in the annoyance of having to disassemble and reassemble everything again ...sorry for the vent but this really pisses me off.

    I have invested in Fanatec for the last 5 years and pre-ordered in trust and good faith despite delays.  I think Fanatec should just send us a replacement wheel ahead of us shipping back the defective one as a return of that trust.


    That would be nice but don't get your hopes up. Today makes day 3 they have had my rma unit and I still haven't gotten a tracking number for the replacement unit. Unsure what the turn around time is. The rma email said as soon as they receive it but that doesn't appear to be the case unless they don't notify us when the new one is shipped. Update: just received notification from FedEx that it will be shipped today. They received it 10am Wednesday and shipped the fixed or replacement unit on Friday in case anyone's wondering about turn around time. I am also in the usa.
  • I'm also waiting for RMA. DD2 has been fine for two weeks and just started having the power issue last night. Support got back to me today and asked for photographic evidence that I had plugged it in correctly. 

    "No support, It's been connected incorrectly for the last two weeks and I just never noticed.....!!!"

    I'd like to presume that a high percentage of users who are willing to pay this sort of money for a wheelbase are like me and have a lot of equipment. The hassle of taking it all apart to take the photo, then put it all back together so as I can race this weekend. Then to take it apart to send it back and reassemble again with my V2.5. Then to remove the V2.5 to install the replacement DD2... that is a lot of hassle.

    I have used Fanatec products all the way back to the GT2RS so believe me I am a fan but this. After the launch was delayed for 4 months and now there's another problem.
    No wonder Fanatec have a bad reputation for quality. 
    I bought a Porsche 918 RSR wheel with the store voucher and put the difference. Even that had a crack in the plastic surround that houses the rev lights where the bolt is. It looks like it had been tightened to much when it had been assembled but I just couldn't be bothered to send it back. If I had paid full price for it though. 400 euro and that's the care and pride that's taken. its just rubbish
  • I think we should be receiving additional compensation for this royal **** up.  We have had to suffer a delay (which was compensated) but then receiving a faulty unit after that. Having to assemble, disassemble, go without a wheel while in RMA, making trips to the post office and packing it up.....
  • I'm also waiting for RMA. DD2 has been fine for two weeks and just started having the power issue last night. Support got back to me today and asked for photographic evidence that I had plugged it in correctly. 

    "No support, It's been connected incorrectly for the last two weeks and I just never noticed.....!!!"

    I'd like to presume that a high percentage of users who are willing to pay this sort of money for a wheelbase are like me and have a lot of equipment. The hassle of taking it all apart to take the photo, then put it all back together so as I can race this weekend. Then to take it apart to send it back and reassemble again with my V2.5. Then to remove the V2.5 to install the replacement DD2... that is a lot of hassle.

    I have used Fanatec products all the way back to the GT2RS so believe me I am a fan but this. After the launch was delayed for 4 months and now there's another problem.
    No wonder Fanatec have a bad reputation for quality. 
    I bought a Porsche 918 RSR wheel with the store voucher and put the difference. Even that had a crack in the plastic surround that houses the rev lights where the bolt is. It looks like it had been tightened to much when it had been assembled but I just couldn't be bothered to send it back. If I had paid full price for it though. 400 euro and that's the care and pride that's taken. its just rubbish
    I know EXACTLY how you feel cos am in the same boat.  To add, I am halfway across the globe.  So shipping takes even longer not to mention cost.
  • edited May 21

    OK I am now really upset and believe I have a valid reason to be.

    My DD1 arrived with a faulty power button and while I am accepting of the fact that these things do happen, I always believed that Fanatec will do right by me.

    I have provided video evidence of this and have been given an RMA number and told I will receive a new unit in exchange.

    I am now told that my shipping costs to the US will NOT be reimbursed (only shipping within the US). This is a significant cost to me as I am located halfway across the globe.

    Let's not even talk about not having the wheel for about a whole month assuming no delays in shipment and the annoyance and effort it takes to assemble, disassemble and reassemble this from my rig.

    I have corresponded with your staff to address this in a more amicable and sensible manner but this does not seem to be turning out well.

    I think many of your global customers would be interested to know how this transpires.

    regards

Sign In or Register to comment.