ClubSport Pedals V3 Damper Kit notchy

Hi,

I have a damper kit and it has not been installed for 3 years and only had 1 hours use when I originally bought it. I uninstalled it very quickly as it made the pedal feel horrible.

I recently sold it on ebay after buying the v3i to replace my v3's and have had it returned as not working as it should, I must admit I just shipped it thinking it would be OK after only 1 hours use, but comparing it to my v3i damper it is very different indeed in feel and alas I fear it is indeed faulty.

It is very notchy through the travel and the first 14mm of travel has no resistance whatsoever and does not seem to provide much of a difference between 1 and 8, albeit there is a tiny bit more resistance at no. 8.

I'm actually thinking it may have been like this from new and why I didn't like it to begin with. Any ideas how I can fix it or what may be wrong with it?

Comments

  • Hi Paul, I recommend that you contact support.
  • edited May 16
    Thanks Dominic, but it's out of warranty. I was wondering if I am alone with this or whether it is a common fault with an easy fix, hence the post.
  • Thanks Dominic, but it's out of warranty. I was wondering if I am alone with this or whether it is a common fault with an easy fix, hence the post.
    I've seen such a damper once before, and there's nothing much you can do to repair. I would still recommend to contact Fanatec Support, just to see what they think/say.
  • Thanks Remco. Glad to know you are still about (remember you from the original WMD forums some years ago) I have logged a support ticket.
  • edited May 16
    I had exactly the same issue. In my case the damper bracket was rubbing against the pedal arm. Symptomatic of over-tightening the bolts that hold it, it seemed, though I was super careful to not tighten them too much, so I think that the bracket's tolerance was just too tight. I don't know for sure.

    Check for scratch marks on the pedal arm, that will confirm it.

    In my case it permanently damaged my accelerator because the damper clamp actually compressed the U-shape of the pedal arm by just enough - like a mm or less - so it could no longer pivot freely on the holding mechanism on the pedal base, even after I had removed the damper kit. And while Fanatec support was superb and I was offered a replacement set of V3 pedals, I just swapped the accelerator mechanism with the clutch seeing as I never use it, and they're identical components, and I didn't want to be without pedals for any period right in the middle of a tense league season.
  • Thanks Ben, Support have already got back to me and have confirmed the unit is out of warranty as I knew already.

    It is a different issue, nothing over tightened here, the damper just has not got enough oil in it.

    Support have suggested (told me outright - the German way I guess is to speak with authority, even if it is totally impossible to be true) that it has leaked over time, but this is not true or even feasible as there would be evidence in the box it has been stored in and oil just does not evaporate in such a short period, maybe in 300,000 years it would have deteriorated into traces of other elements such as buried fossils or trees, but not in 3 years stored in an attic (generally quite cold)

    I will disassemble it and see if I can add some motorcycle damper/fork oil, I have asked support for the grade they use and quantity required... but doubt they will share that information with me.


Sign In or Register to comment.