Fanatec CSW Base V2 not turning on.

After firmware update is completed the wheel fails to restart automatically and auto calibrate, with the red ring around start bottom continuous flashing, it just might be dead as the base is 3yrs old, it's got me stumped



Wheel Base Model (product ID):  Fanatec CSW V2

Steering Wheel Model (product ID):   ClubSport BMW M3 GT2

Driver Version:   328

Base FW Version:   627

Wheel FW Version:  

Pedals Model:  ClubSport Pedals V3

Pedals FW  Version:  1.30

Comments

  • edited June 7
    Did you try and re-flash the firmware (when base is off, press and hold the power button until the ring turns blue and the firmware updater is started automatically on your PC)? Did you leave off your rim on purpose (and if yes, why)?

    If it keeps doing this, please contact Fanatec Support through email or chat as it may then point to a hardware issue.
  • edited June 7
    Did you try and re-flash the firmware (when base is off, press and hold the power button until the ring turns blue and the firmware updater is started automatically on your PC)? Yep tried doing that   Did you leave off your rim on purpose (and if yes, why)? No rim was off for clearance, thou I did try with and without rim and still made zero difference

    If it keeps doing this, please contact Fanatec Support through email or chat as it may then point to a hardware issue. Yep been in contact Fanatec Support, just waiting on there reply


    Cheers mate 

  • edited June 9
    delated
Sign In or Register to comment.