Handbrake not working - always pulled - DD2

Since I switched to the DD2 I can’t get the handbrake working anymore. I already upgraded the Firmware from 335 to 340 but nothing changed. It seems that the handbrake is always pulled. Even if I unplug the handbrake, it stays like this. It worked great with the csl elite base and the 335 driver. I have no Fanatec pedals anymore, so there is no manual calibration checkbox. (I think that’s the reason) Any advise?
Tagged:

Comments

  • Check the cable and the jack, the 3.5mm jack could be bent internally leading to issues you are experiencing. I had a similar issue with mine - ended up replacing the jack and it now works again.
  • That would make sense, if it only happens, when the handbrake is plugged in. But even with unplugged handbrake and restarting the pc and the wheelbase, the firmware tool shows the same as in the picture above.
  • Just reupdated base and motor firmware without handbrake plugged in, restarted pc and base. Handbrake shows pulled.
  • just found out by chance, that the handbrake works normally, when the base is in v2.5 compability mode...
  • That sounds unusual Thomas, I suggest that you contact our support team.
  • edited August 12
    Ok, i tried a different USB port and suddenly everything works like it should :smiley: [CLOSED]
Sign In or Register to comment.